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1. INTRODUÇÃO 
Os métodos tradicionais para a solução numérica de equações diferenciais são os 

Métodos de Diferenças Finitas (MDF), de Volumes Finitos (MVF) e de Elementos Finitos 
(MEF). Com o grande desenvolvimento experimentado pelos métodos numéricos e a 
consequente penetração dos mesmos na engenharia, não raramente se travam discussões 
polêmicas a respeito da eficiência e da generalidade dos diversos métodos. Muitas afirmações 
acerca desses métodos são oriundas do desconhecimento da natureza dos mesmos, e uma breve 
revisão é importante para o seu entendimento. 

Historicamente, o MDF foi sempre empregado na área de mecânica dos fluidos, 
enquanto o MEF o foi para a área estrutural na solução de problemas de elasticidade. Esses 
problemas, do ponto de vista físico, são completamente diferentes, pois os de escoamentos são 
altamente não-lineares, por resolverem as equações de Navier-Stokes, enquanto os da 
elasticidade não possuem os termos advectivos e assemelham-se a problemas puramente 
difusivos de transferência de calor, de característica linear. Foi natural, portanto, o fato de os 
pesquisadores do MDF terem se concentrado na tentativa de dominar as não-linearidades dos 
termos advectivos e no problema do difícil acoplamento entre as equações, dificuldades não 
encontradas em problemas de elasticidade. 

Por essa razão, foi deixado em segundo plano no MDF o problema do tratamento de 
geometrias complexas, e o método teve todo o seu desenvolvimento baseado em sistemas 
coordenados ortogonais, como o cartesiano, o cilíndrico e o esférico, principalmente. Por essa 
razão, muitos vinculam equivocadamente, o MDF com sistemas de coordenadas ortogonais, 
quando, na verdade, ele pode ser aplicado a qualquer tipo de malha, mesmo não-estruturada. 
Apenas os procedimentos de cálculo de derivadas numéricas ao longo de eixos coordenados, 
quando os pontos da malha não estão sobre esses eixos, são mais complicados. 

Por outro lado, o MEF teve seus desenvolvimentos fundamentais na área de 
elasticidade, empregando malhas não-estruturadas do tipo triangular, o que permite que 
problemas em geometrias complexas possam ser resolvidos. Até o início da década de 1970, 
tinha-se, portanto, o MDF com grande experiência na área de fluidos, mas sem habilidades para 
tratar geometrias complexas, e o MEF hábil no tratamento da geometria, mas sem ferramentas 
para tratar os termos advectivos presentes nas equações do movimento. As primeiras tentativas 
de uso do método de Galerkin para problemas com advecção forte não tiveram sucesso, uma vez 
que o método de Galerkin é adequado apenas para problemas puramente difusivos. O uso do 
método de Galerkin em elementos finitos é equivalente ao uso de diferenças centrais em 
diferenças finitas, ambos produzindo instabilidade em problemas de advecção dominante. 

Esse e outros problemas similares, que possuem a adequada interpretação física pelo 
não- funcionamento, motivaram pesquisas para o aprimoramento do método dos volumes finitos 
(MVF), no qual as equações aproximadas são obtidas através de balanços de conservação no 
volume elementar. A observação do caráter físico de cada termo da equação diferencial permitiu 
que métodos mais robustos fossem desenvolvidos. A possibilidade de associar a interpretação 
física à matemática influiu de modo considerável para que praticamente todos os analistas 
envolvidos com o MDF passassem a usar o MVF. Esses dois métodos, por serem semelhantes 
para algumas situações, são muitas vezes confundidos. Deve ficar claro que o MDF é 
simplesmente a substituição do operador diferencial pelo seu correspondente numérico, 
enquanto o MVF realiza um balanço de conservação da propriedade para cada volume 
elementar para obter a correspondente equação aproximada. 

Portanto, tanto o MDF como o MEF não trabalham com volumes de controle e sim 
apenas com os pontos da malha, e, como conseqüência, não são conservativos em nível discreto. 

Uma grande transformação na área numérica em fluidos processou-se em meados da 
década de 1970, quando os sistemas coordenados ortogonais convencionais começaram a ceder 
espaço para os sistemas coordenados generalizados coincidentes com a fronteira do domínio, e o 
MVF passou a resolver problemas em geometrias irregulares. Até os últimos 5 anos, era a 
discretização dominante nos importantes pacotes comerciais disponíveis no mercado para a 
solução de problemas de escoamento de fluidos com transferência de calor. Atualmente, junto 
com a opção do uso de coordenadas generalizadas, esses softwares oferecem a alternativa do 
uso de malhas não-estruturadas. 
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No âmbito do MEF passou-se a empregar outras funções de interpolação para permitir 
o tratamento adequado dos termos advectivos. As funções do tipo Petrov-Galerkin, que 
ponderam os efeitos difusivos e advectivos, semelhantes aos esquemas híbridos empregados em 
volumes finitos, possibilitaram um expressivo avanço no MEF na área de escoamento de 
fluidos. Depois, formulações em  que essas funções são desenvolvidas ao longo da linha de 
corrente, também equivalente aos esquemas Skew usados em volumes finitos, permitiram que o 
MEF passasse, também, a tratar de problemas de fluidos, minimizando os efeitos de difusão 
numérica. 

Atualmente, um grande esforço de pesquisa está sendo dedicado ao desenvolvimento 
de métodos em volumes finitos usando malhas não-estruturadas, semelhantes, portanto, àquelas 
usadas em elementos finitos. No panorama atual, observa-se que ambos os métodos, MVF e 
MEF, estão resolvendo problemas fortemente advectivos, inclusive com ondas de choque, em 
geometrias arbitrárias, mostrando que existe entre eles uma forte semelhança em termos de 
generalidade. Se olharmos do ponto de vista matemático, não poderia ser diferente, uma vez que 
todos os métodos numéricos podem ser derivados o método dos resíduos ponderados, 
empregando-se diferentes funções-peso. 

No contexto dos pacotes comerciais, entretanto, o MVF é ainda o método empregado 
em todos aqueles com penetração industrial. A preferência é em função da robustez, devido às 
características conservativas do MVF. Em escoamentos de fluidos, é muito importante satisfazer 
os princípios de conservação em nível discreto, característica dos MFV, pois se o que se busca 
com um método numérico é a solução da equação diferencial, que é a representação da 
conservação da propriedade em nível de ponto, parece lógico que as equações aproximadas 
representem a conservação em nível de volumes finitos. Dessa forma, não existe a possibilidade 
da existência de geração/sumidouros de quantidades, como massa, quantidade de movimento e 
energia, no interior do domínio de cálculo. Por outro lado, se a conservação das propriedades é 
satisfeita apenas via condições de contorno, podem existir gerações/sumidouros das 
propriedades de origem numérica dentro do domínio, o que modificara o perfil da solução na 
região. 

Também a depuração de um programa computacional fica mais fácil quando o analista 
tem etapas a serem conferidas. Como no MVF os balanços de conservação devem ser satisfeitos 
em nível de volumes elementares, para qualquer tamanho de malha, todos os princípios de 
conservação podem ser conferidos em uma malha bastante grosseira. Ou seja, quase tudo pode 
ser feito manuseando-se poucos resultados em execuções rápidas no computador. Em outros 
métodos, pode-se apenas conferir a solução com uma malha refinada, já que o conceito de 
balanços em volumes elementares não existe. 

Recentes desenvolvimentos mostram também o MEF aplicado em nível de volumes 
elementares, conhecidos como Mixed-Finite Elements Methods [2]. Nesses métodos, dentro do 
formalismo de elementos finitos, são respeitados os princípios de conservação, principalmente 
para a massa. Alguns desses métodos adotam, inclusive, o clássico arranjo desencontrado de 
variáveis entre pressão e velocidade, uma prática rotineira no método dos volumes finitos desde 
o início da década de 1970. 

Existem importantes variáveis do MVF, já que qualquer procedimento numérico que 
obtém suas equações aproximadas através dos balanços é um método de volumes finitos. Em 
uma delas estão incluídos aqueles que utilizam discretização através de um sistema de 
coordenadas global, o chamado método em coordenadas curvilíneas, ou boundary-fitted 
coordinates, e que será tratado em detalhes neste texto. Outra variante engloba os métodos que 
utilizam, principalmente, malhas não estruturadas e que criam volumes de controle para os 
balanços a partir de discretizações triangulares ou de paralelogramos, em 2D, e de tetraedros e 
hexaedros em 3D. Dentro dessa classe estão os métodos cujos volumes de controle são criados 
pelo método das medianas [2] e denominados CVFEM - Control Volume-based Finite Elements 
Methods, (Elementos Finitos baseados no Volume de Controle). Essa denominação é ambígua, 
pois dá a entender tratar-se de um método de elementos finitos que utiliza volumes de controle 
para balanços de propriedade. Na realidade, não é um método de elementos finitos e, sim, de 
volumes finitos, e o que é semelhante ao método dos elementos finitos é apenas a definição dos 
elementos e as respectivas funções de forma para as interpolações no interior do elemento. Um 
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nome mais adequado para essa classe de métodos seria EbFVM - Element-based Finite Volume 
Methods, ou Volumes Finitos baseados em Elementos. 

Ainda na classe dos MVF, temos aqueles cujos volumes de controle são diafragmas de 
Voronei, obtidos a partir de uma triangulação de Delaunay. Nesse caso, a discretização é 
localmente ortogonal e apenas dois pontos da malha são necessários para a determinação correta 
dos fluxos. Todos esses métodos serão tratados em Maliska, 2004. 

Um outro método que ganhou espaço na década passada é o método dos elementos no 
contorno (BEM - Boundary Element Method). Sua vantagem é a possibilidade de tratar apenas 
com a discretização da fronteira, sem a necessidade de discretizar o domínio interno. O método 
é aplicado quando é possível transferir a influência do operador do domínio para a fronteira. 
Apesar de atraente, é um método que ainda está longe de responder ás solicitações dos 
problemas complexos resolvidos pelos outros métodos. Sem dúvida, é uma área de pesquisa que 
merece esforços. 

Com os crescentes avanços computacionais, as técnicas de CFD vem a cada ano 
ampliando seu campo de aplicações, tanto acadêmicas como industriais, e os pacotes (softwares) 
comerciais, cada vez mais amigáveis, difundem-se na mesma proporção. Existem muitos 
pacotes computacionais disponíveis no mercado, alguns mais específicos e outros mais 
genéricos, capazes de resolver uma enorme gama de problemas de engenharia.  

A Ansys Inc., atual fornecedora dos pacotes de CFD - Computational Fluid Dynamics 
- CFX e Fluent, disponibiliza numa única interface ambos os softwares. O CFX, que trata-se de 
um código genérico de Dinâmica de Fluidos Computacional, baseado na técnica de volumes 
finitos, o qual combina um solver avançado com poderosos recursos de pré e pós-
processamento, além de interfaces com outras linguagens de programação sob a forma de 
interações com sub-rotinas ou pacotes externos, será o foco de estudo dessa curso. No Brasil a 
empresa que fornece este pacote chama-se ESSS, e fica sediada na cidade de Florianópolis, SC. 

De uma forma geral, o modelamento para CFD envolve, tradicionalmente, configurar 
a geometria do problema, gerar uma malha adequada e aplicar as condições de contorno. Para 
geometrias complexas, as limitações de geração de malha têm resultado na necessidade de 
grandes períodos de tempo para definir o problema, mas com plenas condições de realização. O 
CFX [1], atualmente na versão 19, contorna esta dificuldade através do uso de pré-processador 
baseado em CAD para a geração de geometria/malha, incorporando poderosas ferramentas de 
criação de geometria com um gerador automático de malhas não estruturadas. O pré-
processador da física do problema, CFX-Pre, permite importar múltiplas malhas, de modo que 
cada seção de geometrias complexas possa utilizar a malha mais aprimorada. 

O CFXinclui as seguintes características: 
 Um solver acoplado que é robusto e confiável; 
 Integração completa entre a definição do problema análise e 

apresentação de resultados; 
 Configuração de processos intuitiva e interativa, usando menus e 

interface gráfica avançada; 
 Help online detalhado. 

2. CFD 

2.1. O QUE É CFD? 
CFD (do inglês, Computational Fluid Dynamics), ou Dinâmica de Fluidos 

Computacional, é uma ferramenta baseada em computação que simula o comportamento de 
sistemas que envolvem escoamentos de fluidos, transferência de calor e outros processos físicos 
relacionados. O CFD funciona através da solução das equações de escoamento de fluidos(em 
uma forma especial) sobre uma região de interesse, com condições de contorno 
especificadas(conhecidas) nas fronteiras daquela região. 

O CFD é, hoje, uma ferramenta de projeto industrial bem estabelecida que ajuda a 
reduzir os tempos de projeto e melhorar processos de engenharia. Além disso, o CFD fornece 
uma alternativa de custo-benefício e precisão aos testes experimentais aplicados a modelos em 
escala, com variações entre as simulações sendo realizadas rapidamente. 
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2.2. A MATEMÁTICA DO CFD 
O conjunto de equações que descreve os processos de quantidade de movimento, 

transferência de calor e massa são conhecidos como as equações de Navier-Stokes. Elas são 
equações diferenciais parciais que foram derivadas no início do século XIX. Elas não possuem 
soluções analíticas, a não ser para situações muito simplificadas, mas podem ser discretizadas 
para serem resolvidas numericamente na sua plenitude. 

Equações que descrevem outros processos - como combustão, por exemplo, podem ser 
resolvidas em conjunto com as equações de Navier-Stokes. Frequentemente, um modelo de 
aproximação é usado para derivar estas equações adicionais, sendo os modelos e turbulência um 
exemplo particular importante. Modelos de transferência de calor por radiação térmica também 
são incorporados, assim como a formulação Euleriana e Lagangeana para tratar de forma 
acoplada fluidos carregando partículas ou gotas de líquidos em meio a um fluido principal. 

Há um grande número de diferentes métodos de solução que são usados nos códigos 
de CFD. O mais comum, e sobre o qual o CFX é baseado, é o chamado Método dos Volumes 
Finitos. 

Neste método, a região de interesse é dividida em pequenas sub-regiões, chamadas de 
volumes de controle. Todas as equações são discretizadas e resolvidas iterativamente para cada 
volume de controle levando em consideração a interface com os demais volumes visinhos ao 
volume de análise na malha computacional. Como resultado, uma aproximação do valor de cada 
variável nos pontos específicos do domínio pode ser obtida. Desta maneira, é possível obter 
uma representação completa do comportamento do escoamento. 

2.3. APLICAÇÕES DE CFD  
CFD é usado por engenheiros e cientistas em diversas áreas. Aplicações típicas 

incluem: 
 Indústria de processos: Misturadores, reatores químicos; 
 Construção: Ventilação de edifícios; 
 Saúde e segurança: Investigação dos efeitos do fogo e da fumaça; 
 Indústria automobilística: Modelamento de combustão, aerodinâmica de 

veículos; 
 Eletrônica: Transferência de calor no interior e ao redor de circuitos eletrônicos; 
 Meio ambiente: Dispersão de poluentes no ar ou na água; 
 Energia: Otimização de processos de combustão; 
 Medicina: Escoamento de sangue através de veias e artérias, etc. 

2.4. METODOLOGIA DO CFD 
CFD pode ser usado para determinar a performance de um componente em um estágio 

de projeto ou pode ser usado para analisar dificuldades com um componente existente e 
conduzir a um projeto melhor otimizado, antevendo possíveis problemas, ou até mesmo 
orientando o andamento do projeto de equipamentos e processos. 

Normalmente, uma simulação realizada através de CFD é constituída por três etapas 
bem definidas: 
 

Pré-processamento →Processamento (solução)→ Pós-processamento 
 

2.4.1. Pré-Processamento 

O Pré-processamento é a etapa de definição e configuração do problema a ser 
analisado. O pré-processamento pode ser dividido em duas partes: 
Geometria/malha 

Este processo interativo é o primeiro estágio de pré-processamento. Seu objetivo é 
produzir uma malha para introduzir no pré-processador a física do problema. Antes que uma 
malha possa ser produzida, um sólido geométrico fechado é necessário. A geometria e a malha 
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podem ser cridas no software ICEM-CFD [1] (incorporado ao pacote da Ansys) ou em uma 
variedade de ferramentas de criação de geometria/malha. Alguns softwares de CAD - Computer 
Aid Design podem também ser usados para a geração da geometria do problema.  

Os passos básicos envolvem para esse processo inicial são: 
 Definição da geometria na região de interesse; 
 Criação de regiões de escoamento de fluidos, regiões de sólidos e nomes de 

superfícies de contorno; 
 Configuração das propriedades da malha e ajustes. 
Este estágio de pré-processamento está ficando cada vez mais automatizado. No CFX-

19, a geometria pode ser importada da maioria dos pacotes de CAD, como acima mencionado, 
usando o formato nativo e a malha de volumes de controle pode ser gerada automaticamente. 
Definição da Física do Problema 

Este processo interativo é o segundo estágio de pré-processamento e é usado para criar 
os dados de entrada do solver. Os arquivos de malha são carregados pelo pré-processador da 
física do problema, aqui o CFX-Pre, e as seguintes propriedades são definidas: 

 Os modelos físicos que devem ser incluídos na simulação são selecionados; 
 As propriedades do fluido são especificadas; 
 As condições de contorno são especificadas. 

2.4.2. Processamento(Solução) 

O solver é o componente que resolve o problema de CFD produzindo os resultados 
solicitados. A etapa de solução é um processo não interativo (batch process, ou em lote). O 
solver resolve o problema de CFD da seguinte maneira: 

 As equações diferenciais parciais são integradas sobre todos os volumes de 
controle na região de interesse. Isto é equivalente a aplicar uma lei de 
conservação (para massa ou quantidade de movimento, por exemplo) para cada 
volume de controle; 

 Estas equações integrais são convertidas para um sistema de equações algébricas 
através de um conjunto de aproximações para os termos das equações integrais; 

 As equações algébricas são resolvidas iterativamente. 
O processo iterativo é necessário por causa da natureza não linear das equações. À 

medida que a solução se aproxima da solução exata diz-se que ela CONVERGE. Para cada 
iteração, um erro, ou resíduo, é registrado como medida da conservação geral das propriedades 
do escoamento. 

Quão próximo a solução final esta da solução exata depende de uma série de 
fatores, incluindo o tamanho e o formato dos volumes de controle e o tamanho dos 
resíduos finais. Processos físicos complexos, como combustão e turbulência, são 
frequentemente modelados usando relações empíricas, e as aproximações inerentes a esses 
modelos também contribuem para diferenças entre a solução obtida por CFD e o escoamento 
real. No entanto, com avanços científicos e dos modelos, os resultados obtidos com CFD são 
muito próximos da situação real, apresentando boa confiabilidade, desde que devidamente 
testados. 

O processo de solução não exige intervenção do usuário e, portanto, é realizado de 
forma não interativa (batch process). 

O solver produz um arquivo de resultados que é passado para o pós-processador. 

2.4.3.  Pós-Processamento 

O pós-processamento é o componente usado para analisar, visualizar e apresentar os 
resultados interativamente. Pós-processamento inclui desde obter valores em pontos do domínio 
até realizar animações complexas. 

Exemplos de algumas características importantes de pós-processadores são: 
 Visualização da geometria e volumes de controle; 
 Visualização de vetores mostrando a direção e a magnitude do escoamento; 
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 Visualização da variação de variáveis escalares (variáveis que tem apenas uma 
magnitude, sem direção, tais como temperatura, concentração de espécies 
químicas, pressão, propriedades, etc.) ao longo do domínio; 

 Cálculos numéricos quantitativos; 
 Animação; 
 Gráfico (x,y); 
 Saída para impressora. 

3. A ESTRUTURA DO CFX 
O CFX consiste de 5 módulos [1] que são ligados pelo fluxo de informação exigido 

para realizar uma análise de CFD, apresentados no diagrama da Fig. 3.1: 

 

 

 

 

 

Figura 3.1- diagrama do fluxo de informação entre os módulos do CFX. 

O CFX é capaz de empregar os seguintes modelos: 
 Escoamentos estacionários e transientes; 
 Escoamentos laminares e turbulentos; 
 Escoamentos subsônicos, transônicos e supersônicos; 
 Transferência de calor por convecção, condução e radiação térmica; 
 Flutuação; 
 Escoamentos não newtonianos; 
 Transporte de componentes escalares não reativos; 
 Escoamentos multifásicos; 
 Combustão e reações químicas; 
 Escoamentos em múltiplos sistemas de referência; 
 Particle tracking. 

3.1. ICEM-CFD 
O ICEM-CFD pode ser usado para especificar a geometria e a malha para os modelos 

de CFD. Também pode importar uma geometria de outro software tipo CAD. 

3.2. CFX-Pre 
A especificação da física do problema, das condições de contorno, dos valores iniciais 

e parâmetros de solução é realizada no CFX-Pre. 
O CFX-Pre pode importar arquivos de malha produzidos pelo ICEM-CFD ou por 

outros geradores de malha. 
Uma gama completa de condições de contorno, incluindo entrada (inlet ), saída 

(outlets), aberturas (opening), paredes sólidas (wall) e simetrias (symetry),  em conjunto com 
condições de contorno para modelos de turbulência e periodicidade, estão disponíveis no 
CFXatravés do CFX-Pre. 

3.3 CFXSOLVER 
A partir de uma especificação gerada no CFX-Pre,o CFXSolver resolve para todas as 

variáveis da simulação. 

CFX Solver 
Manager 

ICEM-CFD 
(geometria/malha) 

CFX-Pre 
(Física) 

CFX Solver 
(Solver) 

CFX-Post 
(pós-proc.) 

Outro software 
de geração de 
malha 
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Uma das características mais importantes do CFX é o uso de um solver acoplado, no 
qual todas as equações termodinâmicas são resolvidas como um único sistema. O solver 
acoplado é mais rápido que o tradicional solver segregado e um número menor de iterações são 
necessárias para obter-se uma solução convergida. 

3.4 CFXSOLVER MANAGER 
O CFXSolver Manager é um módulo que oferece maior controle sobre o 

gerenciamento do processo de solução. Suas principais funções são: 
 Especificar os arquivos de entrada para o CFXSolver; 
 Iniciar/parar o CFXSolver; 
 Monitorar o progresso da solução; 
 Configurar o CFXSolver para processamento paralelo. 

3.5 CFX-POST 
O CFX-Post fornece ferramentas gráficas de pós-processamento de ultima geração que 

permitem analisar e apresentar os resultados das simulações do CFX-19. 
Algumas características importantes incluem: 
 Pós-processamento quantitativo; 
 Linha de comando, arquivo de sessão; 
 Variáveis definidas pelo usuário; 
 Geração de uma variedade de objetos gráficos onde a visibilidade, transparência, 

cor e renderização de linhas ou faces podem ser controladas; 
 'Power Syntax' para permitir arquivos de sessões programados, etc. 

4.TIPOS DE ARQUIVOS DO CFX-19 
Durante o processo de simulação (geração do modelo, solução e análise de resultados) 

diferentes arquivos são criados pelos módulos do CFX-19. Este capítulo descreve alguns destes 
arquivos e o seu propósito [1]. 

4.1. ICEM-CFD 
 Arquivo de geometria (*.tin); 
 Arquivo de malha (*.uns); 
 Arquivo de projeto(*.prj); 
 Arquivo de parâmetros(*.par); 
 Arquivo de atributos(*.fbc); 
 Arquivo GTM(Geometry, Topology and Mesh) (*.msh). 

4.2. CFX-PRE 
Entrada e Saída: 

 Arquivo GTM do CFX-19(*.gtm); 
 Arquivos de Definições do CFX-19(*.def); 
 Arquivo de Sessão do CFX-Pre(*.pre); 
 Arquivo de Caso do CFX-19(*.cfx); 
 Arquivo CCL (*.ccl). 

Apenas Entrada: 
 Arquivos de Resultados do CFX (*.res); 
 Outro arquivo com resultados sobre a malha. 

4.3 CFXSOLVER 
Entrada: 

 Arquivo de Definições do CFX (*.def); 
 Arquivo de Resultados do CFX (*.res), para o reinicio da simulação. 

Saída: 
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 Arquivo de Resultados do CFX (*.res); 
 Arquivo de Saída(*.out); 
 Arquivos pra outros pós-processadores. 

4.4 CFX-POST 
Entrada: 

 Arquivo de Resultados (*.res); 
 Arquivo de Sessão do CFX-Post(*.cse); 
 Arquivo de Sessão do CFX-Post(*.cst); 
 Arquivo de Definições do CFX (*.def); 

Saída: 
 Arquivos gráficos; 
 Arquivos de exportação de dados. 

5. ICEM-CFD 
O ICEM-CFD oferece ao usuário um ambiente unificado para geração de malha. Ele 

combina, sob o mesmo GUI, a seguinte funcionalidade: 
 Manager - Gerenciamento do projeto, configurações e I/O; 
 Geometry creation/repair - Ferramenta para criar/adicionar geometrias, assim 

como para reparar partes incorretas; 
 Mesh creation - Hexa, Tetra, Prism. Todos os tipos de geradores de malha podem 

ser disparados de dentro do ICEM-CFD; 
 Mesh editing - Diagnóstico, edição e suavização de malha; 
 Solution - Configuração da solução para o CFX; 
 View Manager - Usado para medir distâncias e ângulos e mudar de vista; 
 Tree - Para gerenciar as partes, assemblies e seu comportamento. 

5.1. CORREÇÃO DA GEOMETRIA 
Antes de gerar uma malha Shell ou Tetra, o usuário deve confirmar se a geometria do 

modelo não possui falhas que possam inibir a criação de uma malha adequada. A Fig. 5.1 
mostra elementos prismáticos e hexaédricos. 

Para criar uma malha, Tetra exige que o modelo contenha um volume fechado. Se, 
na geometria, há buracos maiores do que os tetraedros de referência para uma localização 
particular, o Tetra não conseguira encontrar um volume fechado. Se o usuário observar 
qualquer buraco no modelo antes da geração da malha, ele deve corrigir os dados de superfície 
para eliminar esses buracos. A maioria dos buracos pode ser encontrada usando a opção Buil 
Topology. Essa opção deve apresentar curvas amarelas para as regiões que possuem grandes 
falhas ou sem superfícies. Se o usuário não detecta nenhum buraco, mas há dúvida quanto à 
integridade do modelo, ele pode rodar o Tetra identifica automaticamente os buracos e 
direciona o usuário a fechá-lo interativamente. 
 
 
 
 
 
 
 
 (a) (b) 

Figura 5.1 – Malas disponíveis para o CFX: (a) Tetra; (b) Hexa. 

5.2 TETRA 
Automatizado a ponto do usuário ter apenas que selecionar a geometria sobre a qual 

será gerada a malha, o Tetra gera malhas de tetraedros diretamente da geometria do CAD, sem 
exigir uma malha inicial de triângulos nas superfícies. 
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Adequado para geometrias complexas, o Tetra oferece diversas vantagens: 
 Rápida configuração do modelo; 
 Não é necessário malha nas superfícies; 
 Geração de malhas diretamente do CAD; 
 Definição do tamanho da célula a partir das superfícies do CAD; 
 Controle sobre o tamanho da célula dentro do volume, 
 Nós e arestas de tetraedros coincidem com os pontos e curvas prescritos; 
 Algoritmo rápido: 1500 células por segundo; 
 Identificação automática de buracos e fácil reparo da malha; 
 Entre outras. 

5.2.1. Detalhes da geometria necessários 

Tetra exige curvas nas posições onde o usuário tem interesse em capturar 
características geométricas onde duas superfícies se interceptam. As curvas no Tetra fornecem 
uma indicação ao gerador de malha que os nós da malha deverão ser alinhados ao longo da 
entidade geométrica. 

Pontos também são necessários para a capturar os cantos das curvas. Se duas curvas se 
interceptam num ângulo muito fechado e o usuário deseja capturar esta característica, um ponto 
tem que ser criado no vértice da interseção. 

5.3. PRISMAS 
Prismas (Fig. 5.2) são usados para gerar malhas híbridas, com camadas de prismas de 

base triangular nas superfícies de contorno e elementos tetraédricos no interior do domínio. 
Comparado a malhas formada apenas por tetraedros, malhas híbridas com camadas de prismas 
próximas às superfícies permitem um melhor modelamento da física do escoamento junto à 
parede, resultando em simulações mais rápidas e resultados mais adequados. 
 
 
 
 
 
 
 
 
 

Figura 5.2 – Tipos de prismas. 

5.4. HEXA - Não disponível no pacote dos laboratórios da URI. 
O ICEM-CFD possui o gerador Hexa, que é um gerador de malha de elementos 

hexaédricos, 3-D, semi-automático, estruturado em multi-blocos ou não estruturado, aplicado 
em superfícies e volumes. A topologia de bloco do modelo é gerada diretamente da geometria 
do CAD. Mais utilizado em geometrias regulares, cilíndricas ou cúbicas. 

6. CFX-PRE 
O CFX-Pre é o modulo de pré-processamento do CFXresponsável pela especificação 

da física do problema, das condições de contorno, dos valores iniciais e dos parâmetros de 
solução, de modo a selecionar o modelo físico empregado na simulação via CFD. O CFX-Pre 
também é utilizado para importar malhas produzidas no ICEM-CFD ou em outros geradores de 
malha. 

Os principais componentes da interface do usuário do CFX-Pre (CFX-Pre user 
interface) são o Viewer, o Object Selector, a barra de menus (menu bar) e as barras de 
ferramentas (tool bars), mostrados na Fig. 6.1. 
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O CFX-Pre possui 4 diferentes modos de operação, como segue: 
 General Mode: este modo pode ser usado para todos os casos; 
 The Turbo Wizard: simplifica a configuração de algumas simulações de turbo-

máquinas; 
 New User Wizard: fornece um número reduzido de opções de modelos e é 

adequado para novos usuários; 
 Model Library Mode: este modo é usado para importar arquivos de bibliotecas pré-

definidos para simulações mais complexas. 
 

 
Figura 6.1 - Componentes principais do CFX-Pre user interface. 

 

6.1. TIPOS DE ARQUIVOS DO CFX-PRE 
Esta seção descreve os tipos de arquivos usados e produzidos pelo CFX-Pre. 

6.1.1. Case Files (*.cfx) 

O arquivo de caso (Case File) contém os dados físicos para a simulação e é usado pelo 
CFX-Pre em conjunto com o arquivo GTM como a "base de dados" (database) para a 
configuração da simulação. Tanto o Case File como o GTM file são gerados quando a 
simulação é salva no CFX-Pre e ambos são exigidos para reabrir uma simulação existente. Para 
reabrir uma simulação, seleciona-se um arquivo de caso no menu File > Open Simulation. O 
arquivo de caso é um arquivo binário e não pode ser editado diretamente. 
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6.1.2. GTM Files (*.gtm) 

O arquivo GTM é um arquivo de geometria, topologia e malha (Geometry, Topology 
and Mesh) usado pelo CFX-Pre. Ele contém todas as informações sobre regiões e malhas 
exigidas para a simulação. Um arquivo GTM é criado para cada nova simulação no CFX-Pre e 
em conjunto com o arquivo de caso(Case File), ele define a simulação no CFX-Pre. Os arquivos 
GTM podem ser lidos no CFX-Post para analisar a malha em detalhes. 

6.1.3 Definition Files (*.def) 

Um arquivo de definição do CFX-19(Definition File) contém a especificação para 
toda a simulação, incluindo a geometria, a malha da superfície, condições de contorno, 
propriedades do fluido, parâmetros de solução e valores iniciais. É criado pelo CFX-Pre e usado 
como arquivo, de entrada no CFXSolver. Um arquivo de definição deve ser escrito quando a 
configuração da simulação foi concluída. Este arquivo é então usado pelo CFXSolver para 
iniciar a solução da simulação. 

6.1.4. Session Files (*.pre) 

Os arquivos de sessão (Session Files) são usados pelo CFX-Pre para gravar a 
Linguagem de Comandos do CFX (CFX Command Language- CCL) dos comandos executados 
durante uma sessão. Esses comandos podem ser novamente executados mais tarde  para 
reproduzir uma sessão. Uma sessão identificada por cfx.xx.pre é automaticamente criada para 
cada sessão do CFX-Pre. Estes arquivos são em formato ASCII e podem ser editados ou escritos 
num editor de texto. 

6.1.5. Arquivos de Malha (Mesh Files) 

Há vários tipos de arquivos de malha que podem ser importados pelo CFX-Pre. 

6.1.6. CCL Files (*.ccl) 

Os arquivos CCL do CFXsão usados pelo CFX-Pre para armazenar os comandos da 
Linguagem de Comando do CFX (CFX Command Language -CCL). Os arquivos CCL diferem 
dos arquivos de sessão pelo fato de que apenas um pequeno trecho do estado atual é armazenado 
em arquivo. Estes arquivos são em formato ASCII e podem ser editados ou escritos num editor 
de texto. 

6.1.7. Result Files (*.res) 

Os arquivos de resultados do CFX(Result Files) podem ser lidos no CFX-Pre da 
mesma forma que um arquivo CCL. Os comandos CCL são extraídos do arquivo de resultados e 
os dados da malha são escritos para um arquivo GTM. 

6.2. VIEWER 
A janela Viewer é utilizada para visualizar os objetos gráficos, tais como as malhas 

importadas. Informações sobre condições de contorno, domínios, fontes pontuais, etc. também 
são apresentados e itens podem ser selecionados com o mouse diretamente da janela. O CFX-
Pre usa a mesma janela Viewer que o CFX-Post e pode ser observada na Fig. 6.2. 
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Figura 6.2 - Janela viewer do CFX-Pre e CFX-Post. 

6.2.1. Operações com o mouse 

Diversas ações podem ser realizadas sobre os objetos gráficos da janela viewer com o 
uso do mouse. Na Fig. 6.3 é apresentada a configuração padrão que relaciona as ações aos 
botões do mouse. Essas configurações podem ser modificadas pelo usuário ao menu Edit > 
Options sob a opção Viewer / Mouse Mapping. 

  
Figura 6.3 - Mapeamento das ações sobre os objetos gráficos da janela Viewer com os botões do 

mouse. 
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6.2.2. Teclas de atalho 
Várias teclas de atalho estão disponíveis para realizar tarefas comuns na janela viewer. 

Estas ações podem ser realizadas clicando-se sobre a janela viewer e pressionando a tecla 
associada. Na Tab. 6.1 são apresentadas as teclas de atalho e suas respectivas ações. 

 
Tabela 6.1 - Teclas de atalho para ações que podem ser realizadas  na janela viewer. 

Tecla Ação 
Espaço Troca entre os modos picking e viewing 
Setas Gira em torno de X eY 
<ctrl> + setas para cima/para baixo Gira em torno de z 
<Shift>+ setas Move a fonte de luz 
1 Uma viewport 
2 Duas viewports 
3 Três viewports 
4 Quatro viewports 
C Centraliza o objeto 
N Troca entre o ortográfico e perspectiva 
R Reinicializa a vista 
U Undo (desfazer) 
U Redo (refazer) 
X Vista em +X 
X Vista em -X 
Y Vista em +Y 
Y Vista em -Y 
Z Vista em +Z 
Z Vista em -Z 

6.3. OBJECT SELECTOR 
A janela Object Selector apresenta um resumo da física que foi definida para a 

simulação. A janela Object Selector contém inicialmente uma lista padrão de objetos sob a 
forma de árvore (tree format), como pode ser observado na Fig. 6.4. Novos objetos são 
mostrados na árvore à medida que são criados. Clicar sobre qualquer objeto do Object Selector 
que está associado a uma região faz com que essa região seja identificada no viewer. Objetos 3D 
são mostrados com uma caixa ao seu redor e objetos 2D são mostrados com uma linha vermelha 
ao redor das arestas. 

 
Figura 6.4 - Descrição da janela Object Selector do CFX - Pre. 
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As estruturas de árvore (tree structures) mostradas no Object Selector refletem a 
estrutura usada na Linguagem de comando do CFX (CFC Command Language - CCL) para a 
definição física. Pode-se selecionar qualquer objeto de árvore e ganhar acesso direto para a 
janela adequada para editar suas configurações. Pode-se, ainda, usar o Object Selector para 
mostrar a definição CCL de um objeto na janela do editor de comandos (Command Editor 
window), onde pode ser editado. 

Uma importante característica do CFX-Pre é a verificação automática da física do 
problema. Os objetos que contém configurações inconsistentes ou incorretas são identificadas 
em vermelho no Object Selector. Mensagens de erro detalhadas são mostradas na janela de 
resumo da validação da física (Physics Validation Summary window). 

6.4. PHISICS CHECKING (VALIDAÇÃO DA FÍSICA) 
À medida que o usuário vai trabalhando através de sua simulação, o CFX-Pre verifica 

continuamente as definições físicas que foram especificadas. Sempre que uma ação é executada, 
uma verificação da física é realizada sobre as definições de CCL (CFX Command Language) 
para todos os objetos criados até aquele ponto. Se uma inconsistência é encontrada na física, o 
objeto associado com o(s) erro(s) é identificado em vermelho na árvore da janela Object 
Selector. 

Além da identificação do nome do objeto, a janela de resumo da validação 
física(Physics Validation Summary window) apresenta todos os tipos de erro da simulação: erros 
globais(em azul) e erros físicos(em vermelho), como pode ser visto na Fig. 6.5. Um duplo 
clique do mouse sobre um item em vermelho no Physical Validation Summary leva o usuário 
para a forma mais adequada de editor o objeto. 
Erros globais(em azul) aplicam-se a toda simulação e apresenta erros que não são erros físicos. 
Erros físicos(em vermelho), envolvem aplicações incorretas da física. 

 
Figura 6.5 - Janela Physics Error Summary do CFX - Pre. 

6.5 UNIDADES E DIMENSÕES 
No CFX, as dimensões são definidas em unidades que são uma combinação de uma ou 

mais unidades separadas. Por exemplo: massa pode ter unidades de [kg], [gramme] ou [lb] 
(entre outras); pressão pode ter unidades de [kg/m3]; [lb/in2] ou [Pa] (entre outras). 

A sintaxe geral para unidades no CFXé definida da seguinte maneira: 
[multiplier|unit|^int], onde multiplier é uma quantidade multiplicadora (por exemplo: mega, 
pico, centi, etc), unit é o termo de unidade (por exemplo: kg, m, J, etc) e int é uma potência 
inteira. Ao se digitar unidades em uma expressão, elas devem estar entre colchete, [...]. Em 
geral, não se vê os colchetes ao selecionar unidades de uma lista de unidades. 

6.6 TIPO DE SIMULAÇÃO 
A janela Simulation Type é usada para especificar se a simulação é estacionária 

(steady state) ou transiente (transient). A janela Simulation Type é aberta através do menu 
Define > Steady / Transient e é apresentada na Fig. 6.6. 

 



15 
 

 
Figura 6.6 - Janela Symulation Type do CFX - Pre. 

6.7. DOMÍNIOS 
O CFX-Pre usa o conceito de domínios (domains) para definir o tipo, as propriedades 

e a região de fluido ou sólido. Domínios são regiões do espaço onde as equações do escoamento 
de fluido ou de transferência de calor são resolvidas. 

Domínios são criados a partir de uma lista de Assemblies, 3D primitive regions e/ou 
3D composite regions que estão associadas com um volume de uma malha importada. Em 
alguns casos, domínios separados deverão ser conectados através de uma interface de domínio 
(domain interface), enquanto que em outros casos nenhuma interface é exigida ou uma interface 
padrão é criada e é apropriada. 

Dentro de domínios de fluidos ou de sólidos, regiões 3D internas podem ser 
associadas a subdomínios (subdomains), que são usados pra criar fontes volumétricas (de 
massa, quantidade de movimento, energia, etc.). 

Condições de contorno podem ser aplicadas a qualquer de uma primitiva 3D que 
estiver incluída em um domínio. 

6.7.1. General Options 

As opções gerais(General Options) são aplicadas a todo o domínio. Quando um novo 
domínio é criado, a janela General Options, Fig. 6.7, é mostrada 
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Figura 6.7 - Janela General Options do CFX - Pre. 

 
 

6.7.2. Fluid Models 

A janela Fluid Models é onde os modelos são relacionados e que serão aplicados a 
todos os fluidos eulerianos da simulação como exemplifica a Fig. 6.8. 
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Figura 6.8 - Janela Fluid Models do CFX - Pre. 

6.8. CONDIÇÕES DE CONTORNO 
Condições de contorno têm que ser aplicadas a todas as regiões nas extremidades de 

seu(s) domínio(s). Condições de contorno podem ser de entrada (inlet), de saída (outlet), 
abertura (opening), de parede (wall) e de simetria (symmetry) (interfaces periódicas são 
especificadas na planilha de interfaces entre domínios - Domain Interfaces). Regiões externas 
sem especificação de condição de contorno assumem automaticamente a condição de parede 
adiabática com não deslizamento (no-slip) e recebem o nome <Domain> Default, onde 
<Domain> corresponde ao nome do domínio condições de contorno internas não especificadas 
são ignoradas. 

6.8.1. Esquema de cores 

Na janela Viewer as condições de contorno são apresentadas com cores em função do 
seu tipo, da seguinte forma: 

 Inlet: setas brancas(apontando para dentro do domínio); 
 Outlet: setas amarelas (apontando para fora do domínio); 
 Opening: setas bidirecionais azuis; 
 Wall: octaedros verdes; 
 Symmetry: setas vermelhas em cada lado da superfície; 
 Interface; 

o Fluid-Fluid, Fluid-Solid e Solid-Solid: octaedros verdes; 
o Periodic: setas semicirculares violetas. 

7. CFX-SOLVER MANAGER 
O CFXSolver Manager permite ao usuário configurar alguns atributos para o cálculo 

de CFD e controlar o CFXSolver interativamente à medida que a solução se desenvolve. Além 
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disso, o CFXSolver pode rodar em "batch mode" (sem interface gráfica), o que é útil para 
cálculos grandes. 

7.1. MONITORANDO E OBTENDO A CONVERGÊNCIA 

7.1.1. O Resíduo  

O Resíduo é uma medida do desequilíbrio local de cada equação de volume de 
controle conservativa. É a mais importante medida de convergência e relaciona-se diretamente 
ao quanto as equações foram resolvidas. 

7.1.2. Julgando a convergência 

É importante destacar que é possível obter-se uma solução que não muda 
significativamente de um passo de tempo para o outro mesmo antes da convergência ser 
atingida. 
Nota: deve-se sempre verificar se o processo de solução parou por ter atingido o critério de 
convergência ou por ter atingido o número máximo de iterações. No último caso, a solução 
ainda não atingiu o nível de convergência especificada. 

8. CFX-POST 

8.1 INTRODUÇÃO  
O CFX-Post é um pós-processador estado da arte e flexível pra o CFX. Foi projetado 

para permitir fácil visualização e pós-processamento quantitativo dos resultados de simulação 
via CFD. 

8.2 THE VIEWER  
Todas as saídas gráficas do CFX-Post são mostradas na janela Viewer. O Viewer que é 

usado no CFX-Post é o mesmo do CFX-Pre e todas as ações do mouse também são as mesmas 
do CFX-Pre. 

9. EXEMPLOS  
Nos anexos dessa apostila encontram-se alguns exemplos iniciais de utilização do 

Ansys CFX. Vários outros exemplos de utilização são encontrados nos tutorias do software. 
Nesse curso apenas alguns serão vistos. Recomenda-se que todos os tutoriais sejam 
implementados pelos usuários do software para que o mesmo obtenha a base necessária de 
operação da plataforma Ansys CFX 

10. BIBLIOGRAFIA  
[1] ANSYS Inc, 2004. “User's guide - CFX Solver Theory”. 
[2] MALISKA, C., R., 2007.  “Transferência de calor e mecânica dos fluidos 

computacional: fundamentos e coordenadas generalizadas”. Segunda edição, 
Rio de Janeiro: Livros Técnicos e Científicos. 

.  
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11. ANEXOS 

11.1- Iniciação ao ICEM CFD – Criando a primeira geometria. 
1- Abrir o ICEM CFD. 

Criando pontos 

2- Em geometry clique create point. 

3- Na caixa create point selecionar, clicar em explicit coordinates:  

Aplique as coordenadas conforme tabela abaixo: a cada ponto criado, confirme em Apply. 

Pontos  X Y Z 

0 0 0 0 

1 0 0 1 

2 1 0 1 

3 1 0 0 

4 0 1 0 

5 0 1 1 

6 1 1 1 

7 1 1 0 

Após todos os pontos serem criados, na arvore de trabalho, clique com o botão direito do mouse 
sobre points e selecione a opção show point names. 

Criando curvas 

4-Em geometry clique em create/modify curve 
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5-Na caixa de dialogo clique em from points: clique em select location e selecione os pontos 0 e 
1 e clique com o botão do meio para confirmar. 

6- Repita o mesmo procedimento selecionando os pontos conforme tabela abaixo: 

1 2 

2 3 

3 0 

0 4 

4 5 

5 1 

5 6 

6 2 

6 7 

7 3 

7 4 

Criando superfícies 

7-Em geometry selecionar create/modify surface 

8-na caixa de dialogo clique em simple surface,  

 method: from 2-4 curves 
 curves selecionar a curva 0,1,2,3, botão do meio para confirmar 

 
9-Repita o mesmo procedimento para os outros 5 lados do cubo. 

Nomeando as partes 

10-Na árvore de trabalho clique com o botão direito sobre o item parts e selecione o item create 
part: 

 em part: lado 0 
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 entities: selecione a surface 0. 

11-Repita o procedimento para os demais lados (6 lados). 
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11.2- Iniciação ao CFX – Quick Setup 
CARACTERÍSTICAS DO TUTORIAL 

Neste tutorial você vai aprender sobre: 
Usar o modo Quick Setup no CFX-Pre para estabelecer o problema; 
Usar linhas de corrente no CFD-Post para traçar o campo de escoamento a partir de um ponto; 
Visualizar a temperatura utilizando planos coloridos e contornos no CFD-Post; 

 

VISÃO GERAL DO PROBLEMA A SER RESOLVIDO 

Este tutorial simula um misturador estático constituído de dois tubos de entrada que fornecem 
água para o interior de um recipiente de mistura; a água sai através do tubo de saída. Um fluxo 
de trabalho geral é estabelecido para analisar o fluxo do fluido dentro e fora do misturador. 
A água entra através dos dois tubos com mesma velocidade mas com temperaturas diferentes. A 
primeira entra a 2m/s e 315K e a segunda entra a 2m/s e 285K. O raio do misturador é de 2m. 
O seu objetivo neste tutorial é entender como usar o ANSYS CFX para determinar a velocidade 
e temperatura da água na saída do misturador. 

 

INICIANDO O CFX 

Primeiramente deve-se criar uma pasta com o nome do tutorial onde estarão contidos os 
arquivos que serão utilizados no programa. Nesta pasta ficarão salvos os arquivos gerados no 
decorrer da simulação, pasta esta que deverá ser inserida no Working Directory. A pasta do 
StaticMixer encontra-se em: 
C:\Documents and Settings\Aluno\Meus documentos\Tutoriais_CFX\StaticMixer 

1- No CFX-Pre selecione File> New Case  
2- Selecione Quick Setup e clique em OK.  
3- Selecione File > Save Case As.  
4- Em File name defina: StaticMixer e clique em Save.  
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Definindo as configurações do problema 
É necessário definir as propriedades do problema neste caso, o fluido e a temperatura 
1-Na janela Simulation Definition  
2-Selecione para Fluid > Water. 
Importando a malha 
Na janela Simulation Definition > Mesh File: 
1- No seu diretório de trabalho selecione StaticMixerMesh.gtm. Clique em Open. 
2- Clique em Next 
Definindo o modelo 
Na janela Physics Definition do display 
1- Em Model Data> Reference Pressure > 1 [atm].  
2- Selecione em Heat Transfer > Thermal Energy.  
3-E em Turbulence >k-Epsilon.  
4-Clique em Next.  
Definindo as conduces de contorno 
Na janela Boundary Definition do display  
1-Delete Inlet e Outlet clicando com o botão direito do mouse (Delete Boundary).  
2-Após deletar os dois, clique com o botão direito para adicionar uma condição de contorno 
(Add Boundary).  
3-Em Name defina in1.  
4-Clique em OK.  
Especificando o escoamento  
Na janela Flow Specification do display.  
1-Em Option> Normal Speed.  
2-Em Normal Speed > 2 [m s^-1]. 
Na janela Temperature Specification do display 
1-Em Static Temperature> 315 [K] 

 

2-Repita os passos anteriores para as seguintes condições 

 

 

Em Operation > Enter General Mode e clique em Finish 

Parâmetros de solução (Solver control) 
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1- Clique em  Solver Control.  
2- Na janela Basic Settings, em Advection Scheme > Option selecione Upwind.  
3- em Convergence Control > Fluid Timescale Control > Timescale Control selecione 
Physical Timescale e ajuste o valor para 2 [s].  
4- Clique em OK. 
Escrevendo CFX-Solver Input (.def) File  

1-Clique em  Define Run  -  
2- Na janela File name > StaticMixer.def.  
3- Clique em Save.  
4- Clique em Overwrite.  
O CFX-Solver input criara um arquivo (StaticMixer.def). CFX-Solver Manager iniciara 
automaticamente clique Define Run na caixa de dialogo.  
 
POST PROCESS RESULTS 
Para visualizar os resultados no post aparecera automaticamente uma janela: 

 

1- Selecione a Opção Post Process Results 

Abrirá a tela do post, onde é possível visualizar imagens com parâmetros calculados durante a 
simulação. 
Exemplo: 

1- Na barra de trabalho em  selecione Plane. Crie um Plane 1 

 
Na janela em Geometry selecione o plano desejado.  
Em color defina Mode> Variable  
Variable> Temperaure 
Clique em Apply. 
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A imagem gerada mostrará o plano escolhido e a variação de temperatura. 
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11.3 – Usando o ICEM CFD – Importar geometria do Solid Edge 
Static Mixer: Importando a Geometria a partir do Solid Edge: 

Primeiramente, para importar uma geometria a partir do programa Solid Edge, deve-se 
salvar o arquivo do Solid Edge na extensão STEP. Em seguida, abrir o programa ICEM 
CFD. 
Importar a geometria criada no programa Solid Edge clicando em File, import 
geometry, STEP/IGES, buscar o arquivo e clicar em abrir. Verificar se a geometria 
possui pontos, curvas e superfícies na árvore de trabalho. 
Nomeando as Partes: 

Clicar com o botão direito em parts, create part. 
Na caixa de diálogo digite ENTRADA 1. 
Clique em select entities, selecione a superfície indicada na figura abaixo e clique com o 
botão do meio do mouse para confirmar a seleção. Repita o mesmo procedimento com a 
ENTRADA 2, SAÍDA, CILÍNDRO, CONE, TAMPA, TUBO ENTRADA 1, TUBO 
ENTRADA 2 e TUBO SAÍDA. 
Criando a Malha: 

Clicar em Mesh, digite em Scale Factor o valor 0.004 e confirme com o botão Apply.  

 

 

 

 

 

 

 

 

 

 

 

 

Em seguida clique em Part Mesh Setup e digite os valores apresentados na figura 
abaixo. 
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Clique em Compute Mesh, e selecione Volume Mesh e preencha os campos conforme 
ilustra a figura abaixo. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Clique em Compute e aguarde até o processo de geração de malha ser concluído. 
Após a criação esta deve ser checada para garantir que não houveram erros em sua 
criação. Para isso, pressione o botão Edit Mesh e clique em Check Mesh. 
Para ajustar os elementos da malha selecione Smooth Mesh Globally fazendo as 
alterações necessárias. 
Alterações dos parâmetros de malha: Deletar a malha; alterar tamanho da malha, 
verificar qualidade da nova malha. Para isso, pressione o botão Edit Mesh e clique em 
Check Mesh. 
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Gerando prismas sobre a superfícies  

Agora, para fazer os elementos prismáticos clique novamente em Compute Mesh e 
selecione a opção Prism Mesh. Após computar a malha, deve-se checar a qualidade da 
malha e fazer os ajustes necessários de acordo com os passos descritos anteriormente.  

Exportando a Malha: 

Clique em Output, Select Solver e marque na caixa de diálogo as opções apresentadas 
na figura abaixo. Depois selecione Write Input, salve o projeto e clique em Done para 
confirmar e fechar a caixa de diálogo. 
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11.4- Iniciação ao CFX – General Mode 
Tutorial 1, segunda parte: Static Mixer Modo-Geral (General Mode) 

Neste tutorial ira se familiarizar com o Modo Geral para prescrições de soluções dos 
problemas no CFX, utilizando uma malha já previamente construída para a geometria 
do Static Mixer, e irá desenvolver conhecimentos sobre como usar o este modo, o 
General Mode, para implementar a solução do problema visto na aula passada no modo 
iniciante, o Quick Setup; 

OBS. Primeiramente deve-se criar um diretório de trabalho com os seguintes arquivos: 

 StaticMixerRefMesh.gtm 
 StaticMixerRef.pre 
 StaticMixer.def (gerado no primeiro exemplo) 
 StaticMixer_001.res (gerado no primeiro exemplo) 

Pré processamento do problema- Domínio, fluido, modelos e condições de contorno 
(CFX Pré) 

I- Criando um novo caso: 
No CFX-Pre, selecione File > New Case.  

1- Select General > New Case na caixa de dialogo que aparecer clique em OK.  
2- Selecione File > Save Case As.  
3- Em File name > StaticMixerRef e clique em Save.  

 

II- Importando a malha  
1- Selecione Arquivo> Importar> Mesh  
2- Na caixa de diálogo selecione StaticMixerRefMesh.gtm do seu diretório de 
trabalho (Trata-se de uma malha que é mais refinado do que o utilizado no Tutorial 1 já 
preparada para este exemplo para o curso.) 
3- Clique em Open. 
 

III- Importando CCL (arquivo pré-definido pela Ansys com parte da modelagem a ser 
usada) 

1. Selecine File > Import > CCL.  
O Import CCL aparecerá numa caixa de diálogo.  

2. Em Import Method, selecione Replace.  
3. Em File type, selecione CFX-Solver Files (*def *res).  
4. Selecione StaticMixer.def criado no primeiro exemplo.  
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5. Clique Open. 
6. Selecione Outline. 

 

IV- Visualizando Configurações de Domínio 

1. Em Outline na arvore de trabalho, em Simulation > Flow Analysis 1, confirme 
com dois cliques Default Domain.  

2. Clique Basic Settings usar configuração atual.  
3. Clique Fluid Models usar configuração atual. 
4. Clique Initialization usar configuração atual. 
5. Clique Close.  

 

V- Visualizando as condições de contorno 

1. Em Default Domain, dois cliques > in1.  
2. Clique em Boundary Details (contem todas as definições para o escoamento) 
3. Clique Close.  

 

VI - Definido parâmetros do Solver 

1. Selecione Insert > Solver > Solver Control da barra de menu clique Solver 

Control . 
2. Aplique as seguintes condições em Basic Settings 

 
3. Clique Apply.  
4. Clique em Advanced Options. 
5. Certifique-se que Global Dynamic Model Control está selecionado.  
6. Clique OK.  

 

VII- Escrevendo a entrada do CFX-Solver (. Def) File 

1. Clique Define Run.  uma caixa de dialogo é exibida. 
2. Aplique a seguinte condição: 

 
3. Clique Save.  

O arquivo de entrada CFX-Solver (StaticMixerRef.def) é criado. CFX-Solver Manager 
é iniciado automaticamente e, na caixa de diálogo selecione Define Run o Solver do 
arquivo de entrada está definido. o Solver Input File está definido.  

4. Se você for notificado no CFX-Pre que o arquivo já existe, clique em 
Overwrite.  

5. Saia do CFX-Pre, salvando a simulação (.cfx). 
 

VIII- Usando CFX-Solver Manager. 

Nessa etapa o usuário tem condições de parar a solução e alterar alguns dados da 
solução e retornar ao solver para continuar o cálculo a partir das modificações. 
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É possível também ver resultados prévios gravados nos Backups para acompanhar a 
solução, dentre outras funções. 
 

Resultados (Post Process Results) 

1. Na caixa de ferramentas selecione Insert > Location > Plane ou em 
Location, clique Plane. 

2. Em Insert Plane na caixa de dialogo, tipo Slice e clique OK.  
3. Aplique os seguintes parâmetros 
 

4.Clique Apply 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Gerando campo de temperaturas: 

1-Aplique o campo de temperaturas sobre esse plano, seguindo abaixo: 

 

 

 

 

2-Clique Apply. 
3-Faça também as linhas de corrente do escoamento, repetindo os procedimentos 

vistos na aula anterior. 
4-Crie em Vector o campo de vetores velocidade. Altere o tamanho dos vetores 

e mude algumas configurações. 
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11.5- Iniciação ao CFX – General Mode: Flow from a Circular Vent 

Tutorial Features 

In this tutorial you will learn about: 
Setting up a transient problem in CFX-Pre. 
Using an opening type boundary in CFX-Pre. 
Making use of multiple configurations in CFX-Pre 
Modeling smoke using additional variables in CFX-Pre. 
Visualizing a smoke plume using an Isosurface in CFD-Post. 
Creating an image for printing, and generating a movie in CFD-Post.  

 
 
In this example, a chimney stack releases smoke that is dispersed into the atmosphere with an 
oncoming side wind of 1 m/s. The turbulence will be set to intensity and length scale with a value of 
0.05, which corresponds to 5% turbulence, a medium level intensity, and with a eddy length scale value 
of 0.25 m. The goal of this tutorial is to model the dispersion of the smoke from the chimney stack over 
time. Unlike previous tutorials, which were steady-state, this example is time-dependent. Initially, no 
smoke is being released. Subsequently, the chimney starts to release smoke. As a postprocessing 
exercise, you produce an animation that illustrates how the plume of smoke develops with time.  
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Starting CFX-Pre  
Prepare the working directory using the following files in the examples directory:  
CircVent.pre 
CircVentMesh.gtm 
Set the working directory and start CFX-Pre. 
Defining a Multiple-Analysis Simulation in CFX-Pre  
If you want to set up the simulation automatically using a tutorial session file, run CircVent.pre..  
In CFX-Pre, select File > New Case.  
Select General and click OK.  
Select File > Save Case As.  
Set File name to CircVent.  
Click Save.  
Importing the Mesh  
Edit Case Options > General in the Outline tree view and ensure that Automatic Default Domain 
is turned off.  
Default Domain generation should be turned off because you will create a new domain manually, later 
in this tutorial.  
Select File > Import > Mesh.  
From your working directory, select CircVentMesh.gtm.  
Click Open.  
Right-click a blank area in the viewer and select Predefined Camera > Isometric View (Z up) from the 
shortcut menu. 
Creating an Additional Variable  
In this tutorial an Additional Variable (non-reacting scalar component) will be used to model the 
dispersion of smoke from the vent.  
From the menu bar, select Insert > Expressions, Functions and Variables > Additional Variable.  
Set Name to smoke.  
Click OK.  
Set Variable Type to Volumetric.  
Set Units to [kg m^-3].  
Click OK.  
Renaming the Analysis  
To rename the existing analysis: 
From the Outline Tree, right-click Simulation > Flow Analysis 1 and click Rename.  
Rename the analysis to Steady State Analysis.  
Creating the Domain  
You will create a fluid domain that includes support for smoke as an Additional Variable.  
To Create a New Domain  

Select Insert > Domain from the menu bar, or click Domain , then set the name to CircVent and 
click OK.  
Apply the following settings 

 
Click OK. 
Creating the Boundaries  
This is an example of external flow, since fluid is flowing over an object and not through an enclosure 
such as a pipe network (which would be an example of internal flow). In external flow problems, some 
inlets will be made sufficiently large that they do not affect the CFD solution. However, the length scale 
values produced by the Default Intensity and AutoCompute Length Scale option for turbulence are 
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based on inlet size. They are appropriate for internal flow problems and particularly, cylindrical pipes. In 
general, you need to set the turbulence intensity and length scale explicitly for large inlets in external 
flow problems. If you do not have a value for the length scale, you can use a length scale based on a 
typical length of the object over which the fluid is flowing. In this case, you will choose a turbulence 
length scale which is one-tenth of the diameter of the vent. For parts of the boundary where the flow 
direction changes, or is unknown, an opening boundary can be used. An opening boundary allows flow 
to both enter and leave the fluid domain during the course of the analysis.  
Inlet Boundary  
You will create the inlet boundary with velocity components set consistently with the problem 
description.  

Select Insert > Boundary from the menu bar or click Boundary .  
Set Name to Wind.  
Click OK.  
Apply the following settings 

 
5. Click OK.  
Opening Boundary  
You will create an opening boundary with pressure and flow direction specified. If fluid enters the 
domain through the opening, it should have turbulence intensity and length scale, as well as smoke 
concentration, set to the same values as for the inlet.  

Select Insert > Boundary from the menu bar or click Boundary .  
Set Name to Atmosphere.  
Click OK.  
Apply the following settings 

 
5. Click OK.  
Inlet for the Vent  
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You will create the vent inlet boundary with a normal velocity of 0.01 m/s as prescribed in the problem 
description and no smoke release. The turbulence level for the inlet vent will be determined from 
turbulence intensity and eddy viscosity ratio.  

Select Insert > Boundary from the menu bar or click Boundary .  
Set Name to Vent.  
Click OK.  
Apply the following settings 

 
5. Click OK.  
Setting Initial Values  
For this tutorial, the automatic initial values are suitable. Review and apply the default settings:  

Click Global Initialization  .  
Review the settings for velocity, pressure, turbulence and the smoke.  
Click OK.  
Setting Solver Control  
CFX-Solver has the ability to calculate physical time step size for steady-state problems. If you do not 
know the time step size to set for your problem, you can use the Auto Timescale option.  

Click Solver Control .  
Apply the following settings 

 
3. Note that Convergence Control > Fluid Timescale Control > Timescale Control is set to Auto 
Timescale.  
4. Click OK 
Creating a Transient Flow Analysis  
In this part of the tutorial, you will duplicate the steady-state analysis and adapt it to set up a transient 
flow analysis in CFX-Pre.  
From the Outline tree view, right-click Simulation > Steady State Analysis and select 
Duplicate.  
Right-click Simulation > Copy of Steady State Analysis and select Rename.  
Rename the analysis to Transient Analysis.  
Modifying the Analysis Type  
In this step you will set the new analysis to a type of transient. Later, you will set the concentration of 
smoke for the transient analysis to rise asymptotically to its final concentration with time, so it is 
necessary to ensure that the interval between the time steps is smaller at the beginning of the 
simulation than at the end.  
In the Outline tree view, ensure that Simulation > Transient Analysis is expanded.  
From the Outline tree view, right-click Simulation > Transient Analysis > Analysis Type 
and select Edit.  
Apply the following settings 
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4. Click OK 
Modifying the Boundary Conditions 
The only boundary condition that needs altering for the transient analysis is the Vent boundary 
condition. In the steady-state calculation, this boundary had a small amount of air flowing through it. In 
the transient calculation, more air passes through the vent and there is a time-dependent concentration 
of smoke in the air. This is initially zero, but builds up to a larger value. The smoke concentration will be 
specified using the CFX Expression Language.  
To Modify the Vent Inlet Boundary Condition  
In the Outline tree view, ensure that Simulation > Transient Analysis > CircVent is 
expanded.  
Right-click Simulation > Transient Analysis > CircVent > Vent and select Edit.  
Apply the following settings: 

 
Leave the Vent details view open for now.  
You are going to create an expression for smoke concentration. The concentration is zero for time t=0 
and builds up to a maximum of 1 kg m^-3.  
Create a new expression by selecting Insert > Expressions, Functions and Variables > Expression from 
the menu bar. Set the name to TimeConstant.  
Apply the following settings 

 
Click Apply to create the expression.  
Create the following expressions with specific settings, remembering to click Apply after each is defined 

 
Plotting Smoke Concentration  
Double-click ExpFunction in the Expressions tree view.  
Apply the following settings 

 
Click Plot Expression.  
The button name then changes to Define Plot, as shown 
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As can be seen, the smoke concentration rises to its asymptotic value reaching 90% of its final value at 
around 7 seconds.  
Click the Boundary: Vent tab.  
In the next step, you will apply the expression ExpFunction to the additional variable smoke as it 
applies to the Transient Analysis boundary Vent.  
Apply the following settings 

 
Initialization Values  
When the Transient Analysis is run, the initial values to the CFX-Solver will be taken from the 
results of the Steady State Analysis. The steady state and transient analyses will be sequenced 
by setting up the configurations of these analyses in a subsequent step. For the moment, you can leave 
all of the initialization data set for the Transient Analysis to Automatic and the initial values will 
be read automatically from the Steady State Analysis results. Therefore, there is no need to 
revisit the initialization settings.  
Modifying the Solver Control  
In the Outline tree view, ensure that Simulation > Transient Analysis > Solver is 
expanded.  
Right-click Simulation > Transient Analysis > Solver > Solver Control and select Edit.  
Set Convergence Control > Max. Coeff. Loops to 3.  
Leave the other settings at their default values. 
Click OK to set the solver control parameters 
Output Control  
To allow results to be viewed at different time steps, it is necessary to create transient results files at 
specified times. The transient results files do not have to contain all solution data. In this step, you will 
create minimal transient results files.  
To Create Minimal Transient Results Files 
In the Outline tree view, double click Simulation > Transient Analysis > Solver > Output 
Control.  
Click the Trn Results tab.  

In the Transient Results tree view, click Add new item , set Name to Transient Results 1, 
and click OK.  
Apply the following settings to Transient Results 1:  
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Click Apply.  

In the Transient Results tree view, click Add new item  set Name to Transient Results 2, 
and click OK.  
This creates a second transient results object. Each object can result in the production of many transient 
results files.  
Apply the following settings to Transient Results 2:  
Click OK.  
Configuring Simulation Control  
With two types of analysis for this simulation, configuration control is used to sequence these analyses.  
Configuration Control for the Steady State Analysis  
To set up the Steady State Analysis so that it will start at the beginning of the simulation:  
In the Outline tree view, ensure that Simulation Control is expanded.  
Right-click Simulation Control > Configurations and select Insert > Configuration.  
Set Name to Steady State.  
Click OK.  
Apply the following settings 

 
Click OK.  
Configuration Control for the Transient Analysis  
To set up the Transient Analysis so that it will start upon the completion of the Steady 
State Analysis:  
Right-click Simulation Control > Configurations and select Insert > Configuration.  
Set Name to Transient.  
Click OK.  
Apply the following settings 

 
    5. Click OK. 
Writing the CFX-Solver Input File  
From the Outline tree view, right-click Simulation Control and select Write Solver Input File.  
Apply the following settings: 

 
Click Save.  
This will create CircVent.mdef as well as a directory named CircVent that contains 
SteadyState.cfg and Transient.cfg.  
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Quit CFX-Pre, saving the case (.cfx) file.  
Obtaining Solutions to the Steady-State and Transient Configurations  
You can obtain a solution to the steady-state and transient configurations by using the following 
procedure.  
Start CFX-Solver Manager. 
From the menu bar, select File > Define Run.  
Apply the following settings 

 
Click Start Run.  
CFX-Solver Manager will start with the solution of the steady-state configuration.  
In the Workspace drop-down menu, select SteadyState_001. The residual plots for six equations 
will appear: U - Mom, V - Mom, W - Mom, P - Mass, K-TurbKE, and E-Diss.K (the three momentum 
conservation equations, the mass conservation equation and equations for the turbulence kinetic 
energy and turbulence eddy dissipation). The Momentum and Mass tab contains four of the plots and 
the other two are under Turbulence Quantities. The residual for the smoke equation is also plotted but 
registers no values since it is not initialized.  
Upon the successful completion of the steady-state configuration, the solution of the transient 
configuration starts automatically. Notice that the text output generated by the CFX-Solver in the Run 
Transient 001 Workspace will be more than you have seen for steady-state problems. This is 
because each timestep consists of several inner (coefficient) iterations. At the end of each timestep, 
information about various quantities is printed to the text output area. The residual for the smoke 
equation is now plotted under the Additional Variables tab.  
Upon the successful completion of the transient configuration, ensure that the check box beside Post-
Process Results is cleared and click OK to close the message indicating the successful completion of the 
transient solution.  
Upon the successful completion of the combined steady-state and transient configurations, ensure that 
the check box beside Post-Process Results is cleared and click OK to close the message indicating the 
successful completion of the simulation.  
In the CFX-Solver Manager, set Workspace to Run CircVent 001.  
From the menu bar, select Tools > Post-Process Results.  
On the Start CFD-Post dialog box, select Shut down CFX-Solver Manager and click OK.  
Viewing the Results in CFD-Post  
In this tutorial, you will create an isosurface to illustrate the pattern of smoke concentration. Also, you 
will view results at different time steps. Finally, you will animate the results to view the dispersion of 
smoke from the vent over time, and you will save the animation as an MPEG file 
Displaying Smoke Density Using an Isosurface 
An isosurface is a surface of constant value of a variable. For instance, it could be a surface consisting of 
all points where the velocity is 1 [m s^-1]. In this case, you are going to create an isosurface of smoke 
concentration (smoke is the Additional Variable that you specified earlier).  
In CFD-Post, right-click a blank area in the viewer and select Predefined Camera > Isometric View (Z up).  
This ensures that the view is set to a position that is best suited to display the results.  
From the menu bar, select Insert > Location > Isosurface, or under Location on the toolbar, click 
Isosurface.  
Click OK to accept the default name.  
Apply the following settings: 

 
Click Apply.  
A bumpy surface is displayed, showing the smoke emanating from the vent.  
The surface is rough because the mesh is coarse. For a smoother surface, you would re-run the problem 
with a smaller mesh length scale.  
The surface will be a constant color because the default settings on the Color tab were used.  
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When Color Mode is set to either Constant or Use Plot Variable for an isosurface, the 
isosurface is displayed in one color.  
In Geometry, experiment by changing the Value setting so that you can see the shape of the plume 
more clearly.  
Zoom in and rotate the geometry, as required.  
When you have finished, set Value to 0.002 [kg m^-3].  
Right-click a blank spot in the viewer and select Predefined Camera > Isometric View (Z up).  
Viewing the Results at Different Time Steps  
When CFD-Post is loaded, the results that are immediately available are those at the final time step; in 
this case, at t = 30 s (this is nominally designated Final State). The Timestep Selector shows the 
Configuration, the step of the Simulation, the Step (outer loop) number, the Time (simulated time in 
seconds) of the configuration and the Type of results file that was saved at that time step for the 
configuration. You can see that Partial results files were saved (as requested in CFX-Pre) for all time 
steps in the transient configuration except for the last one.  

Click Timestep Selector .  
Load the results for a Time value of 2 s by double-clicking the appropriate row in the Timestep Selector.  
After a short pause, the Current Timestep (located just below the title bar of the Timestep Selector) will 
be updated with the new time step number.  
Load the time value of 4 s using the Timestep Selector.  
The smoke has now spread out even more, and is being carried by the wind.  
Double-click some more time values to see how the smoke plume grows with time.  
Finish by loading a time value of 12 s. 
Generating Titled Image Files 
You can produce titled image output from CFD-Post. 
Adding a Title  
First, you will add text to the viewer so that the printed output has a title.  

Select Insert > Text from the menu bar or click Create text .  
Click OK to accept default name.  
In the Text String box, enter the following text 

 
Select Embed Auto Annotation.  
Set Type to Time Value.  
In the text line, note that <aa> has been added to the end. This is where the time value will be placed.  
Click Apply to create the title.  
Click the Location tab to modify the position of the title.  
The default settings for text objects center text at the top of the screen. To experiment with the position 
of the text, change the settings on the Location tab.  
Under the Appearance tab, change Color Mode to User Specified and select a new color.  
Click Apply.  
JPEG output  
CFD-Post can save images in several different formats. In this section you will save an image in JPEG 
format.  

Select File  >  Save Picture, or click Save Picture .  
Set Format to JPEG.  

Click Browse next to the File data box.  
Browse to the directory where you want the file saved. 
Enter a name for the JPEG file. 
Click Save to set the file name and directory.  
This sets the path and name for the file. 
To save the file, click Save on the Save Picture dialog box.  
To view the file or make a hard copy, use an application that supports JPEG files.  
Turn off the visibility of the text object to hide it. 
Generating a Movie  
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You can generate an MPEG file to show the transient flow of the plume of smoke. To generate a movie 
file, you use the Animation dialog box.  
In the Timestep Selector, ensure that a time value of 0 s is loaded.  

Click Animation .  
Ensure that Quick Animation is selected.  
Position the geometry so that you will be able to see the plume of smoke.  
In the object tree of the Animation dialog box, click Timesteps.  
Click More Animation Options to show more animation settings.  

Ensure that the Repeat forever button  next to Repeat is not selected (not depressed).  
Select Save Movie.  
Set Format to MPEG1.  

Click Browse next to Save Movie.  
Set File name to CircVent.mpg.  
If required, set the path location to a different directory. 
Click Save.  
The movie file name (including path) has been set, but the animation has not yet been produced.  

Click Play the animation .  
The movie will be created as the animation proceeds. 
This will be slow, since results for each timestep will be loaded and objects will be created.  
To view the movie file, you need to use a viewer that supports the MPEG format.  

 
When you have finished, quit CFD-Post. 


